Mac 升级 golang

在使用 VS Code 编写代码时提示 golang 版本太低有个插件用不了了,于是升级 golang,然后在 ~/.bash_profile 中修改 GOROOT 的路径。

brew upgrade golang
1

但在编译代码的时候提示 compile: version "go1.14.14" does not match go tool version "go1.11.6" ,原来是当前环境变量中没有加载 go1.14.14

打开一个新的终端重新加载即可(source 没用,奇怪),看下版本,重新编译正常。

go version

go version go1.14.14 darwin/amd64
1
2
3
访客IP ,您的网络 访问优先

本站是个人博客,书写大数据、数据科学等领域的原创学习记录,转载请注明出处

本站运行于 腾讯云 腾讯云